CVE-2015-6587

NameCVE-2015-6587
DescriptionThe vlserver in OpenAFS before 1.6.13 allows remote authenticated users to cause a denial of service (out-of-bounds read and crash) via a crafted regular expression in a VL_ListAttributesN2 RPC.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-342-1, DSA-3320-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openafs (PTS)wheezy1.6.1-3+deb7u5fixed
wheezy (security)1.6.1-3+deb7u7fixed
jessie (security), jessie1.6.9-2+deb8u5fixed
stretch1.6.20-2fixed
buster, sid1.6.21-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openafssource(unstable)1.6.13-1medium
openafssourcejessie1.6.9-2+deb8u3mediumDSA-3320-1
openafssourcesqueeze1.4.12.1+dfsg-4+squeeze4mediumDLA-342-1
openafssourcewheezy1.6.1-3+deb7u3mediumDSA-3320-1

Notes

http://www.openafs.org/pages/security/OPENAFS-SA-2015-006.txt

Search for package or bug name: Reporting problems