CVE-2015-6660

NameCVE-2015-6660
DescriptionThe Form API in Drupal 6.x before 6.37 and 7.x before 7.39 does not properly validate the form token, which allows remote attackers to conduct CSRF attacks that upload files in a different user's account via vectors related to "file upload value callbacks."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3346-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
drupal7 (PTS)wheezy7.14-2+deb7u12fixed
wheezy (security)7.14-2+deb7u16fixed
jessie (security), jessie7.32-1+deb8u9fixed
stretch (security), stretch7.52-2+deb9u1fixed
buster, sid7.56-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
drupal6source(unstable)(unfixed)medium
drupal6sourcesqueeze(unfixed)end-of-life
drupal7source(unstable)7.39-1medium
drupal7sourcejessie7.32-1+deb8u5mediumDSA-3346-1
drupal7sourcewheezy7.14-2+deb7u11mediumDSA-3346-1

Notes

https://www.drupal.org/SA-CORE-2015-003
http://www.openwall.com/lists/oss-security/2015/08/21/5

Search for package or bug name: Reporting problems