CVE-2015-6817

NameCVE-2015-6817
DescriptionPgBouncer 1.6.x before 1.6.1, when configured with auth_user, allows remote attackers to gain login access as auth_user via an unknown username.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pgbouncer (PTS)stretch1.7.2-2fixed
buster1.9.0-2fixed
bullseye1.15.0-1fixed
bookworm, sid1.16.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pgbouncersourcesqueeze(not affected)
pgbouncersourcewheezy(not affected)
pgbouncersourcejessie(not affected)
pgbouncersource(unstable)1.6.1-1

Notes

[jessie] - pgbouncer <not-affected> (Introduced in 1.6)
[wheezy] - pgbouncer <not-affected> (Introduced in 1.6)
[squeeze] - pgbouncer <not-affected> (Introduced in 1.6)
http://web.archive.org/web/20150905195759/http://pgbouncer.github.io/2015/09/pgbouncer-1-6-1/
https://github.com/pgbouncer/pgbouncer/issues/69
https://www.openwall.com/lists/oss-security/2015/09/04/3

Search for package or bug name: Reporting problems