CVE-2015-6834

NameCVE-2015-6834
DescriptionMultiple use-after-free vulnerabilities in PHP before 5.4.45, 5.5.x before 5.5.29, and 5.6.x before 5.6.13 allow remote attackers to execute arbitrary code via vectors related to (1) the Serializable interface, (2) the SplObjectStorage class, and (3) the SplDoublyLinkedList class, which are mishandled during unserialization.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-341-1, DSA-3358-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.6.13+dfsg-1high
php5sourcejessie5.6.13+dfsg-0+deb8u1highDSA-3358-1
php5sourcesqueeze5.3.3.1-7+squeeze28highDLA-341-1
php5sourcewheezy5.4.45-0+deb7u1highDSA-3358-1

Notes

https://bugs.php.net/bug.php?id=70172
https://bugs.php.net/bug.php?id=70365
https://bugs.php.net/bug.php?id=70366
http://www.openwall.com/lists/oss-security/2015/09/07/5
Fixed in 5.5.45 and 5.6.13

Search for package or bug name: Reporting problems