CVE-2015-6838

NameCVE-2015-6838
DescriptionThe xsl_ext_function_php function in ext/xsl/xsltprocessor.c in PHP before 5.4.45, 5.5.x before 5.5.29, and 5.6.x before 5.6.13, when libxml2 before 2.9.2 is used, does not consider the possibility of a NULL valuePop return value before proceeding with a free operation after the principal argument loop, which allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted XML document, a different vulnerability than CVE-2015-6837.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-341-1, DSA-3358-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
hhvm (PTS)buster, sid3.21.0+dfsg-2fixed
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hhvmsource(unstable)3.12.1+dfsg-1medium
php5source(unstable)5.6.13+dfsg-1medium
php5sourcejessie5.6.13+dfsg-0+deb8u1mediumDSA-3358-1
php5sourcesqueeze5.3.3.1-7+squeeze28mediumDLA-341-1
php5sourcewheezy5.4.45-0+deb7u1mediumDSA-3358-1

Notes

https://bugs.php.net/bug.php?id=69782
http://www.openwall.com/lists/oss-security/2015/09/07/5
Fixed in 5.5.45 and 5.6.13
https://github.com/facebook/hhvm/commit/f358ec0e905df41feaa9dc75f4dee814cfe5a60a

Search for package or bug name: Reporting problems