CVE-2015-6908

NameCVE-2015-6908
DescriptionThe ber_get_next function in libraries/liblber/io.c in OpenLDAP 2.4.42 and earlier allows remote attackers to cause a denial of service (reachable assertion and application crash) via crafted BER data, as demonstrated by an attack against slapd.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-309-1, DSA-3356-1
NVD severitymedium
Debian Bugs798622

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openldap (PTS)stretch2.4.44+dfsg-5+deb9u4fixed
stretch (security)2.4.44+dfsg-5+deb9u8fixed
buster, buster (security)2.4.47+dfsg-3+deb10u6fixed
bullseye, sid2.4.57+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openldapsourcesqueeze2.4.23-7.3+deb6u2DLA-309-1
openldapsourcewheezy2.4.31-2+deb7u1DSA-3356-1
openldapsourcejessie2.4.40+dfsg-1+deb8u1DSA-3356-1
openldapsource(unstable)2.4.42+dfsg-2798622

Notes

http://www.openldap.org/devel/gitweb.cgi?p=openldap.git;a=commitdiff;h=6fe51a9ab04fd28bbc171da3cf12f1c1040d6629
http://www.openldap.org/its/index.cgi/Software%20Bugs?id=8240;selectid=8240
https://www.openwall.com/lists/oss-security/2015/09/11/2

Search for package or bug name: Reporting problems