CVE-2015-7196

NameCVE-2015-7196
DescriptionMozilla Firefox before 42.0 and Firefox ESR 38.x before 38.4, when a Java plugin is enabled, allow remote attackers to cause a denial of service (incorrect garbage collection and application crash) or possibly execute arbitrary code via a crafted Java applet that deallocates an in-use JavaScript wrapper.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3393-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceweasel (PTS)wheezy, wheezy (security)38.8.0esr-1~deb7u1fixed
jessie (security)38.8.0esr-1~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceweaselsource(unstable)38.4.0esr-1medium
iceweaselsourcejessie38.4.0esr-1~deb8u1mediumDSA-3393-1
iceweaselsourcesqueeze(unfixed)end-of-life
iceweaselsourcewheezy38.4.0esr-1~deb7u1mediumDSA-3393-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2015-130/

Search for package or bug name: Reporting problems