CVE-2015-7224

NameCVE-2015-7224
Descriptionpuppetlabs-mysql 3.1.0 through 3.6.0 allow remote attackers to bypass authentication by leveraging creation of a database account without a password when a 'mysql_user' user parameter contains a host with a netmask.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
puppet-module-puppetlabs-mysql (PTS)jessie2.3.1-1fixed
stretch3.10.0-1fixed
bullseye, buster, sid5.3.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puppet-module-puppetlabs-mysqlsource(unstable)3.6.1-1high
puppet-module-puppetlabs-mysqlsourcejessie(not affected)

Notes

[jessie] - puppet-module-puppetlabs-mysql <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems