CVE-2015-7511

NameCVE-2015-7511
DescriptionLibgcrypt before 1.6.5 does not properly perform elliptic-point curve multiplication during decryption, which makes it easier for physically proximate attackers to extract ECDH keys by measuring electromagnetic emanations.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3474-1, DSA-3478-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgcrypt11 (PTS)wheezy1.5.0-5+deb7u4fixed
wheezy (security)1.5.0-5+deb7u6fixed
libgcrypt20 (PTS)jessie (security), jessie1.6.3-2+deb8u4fixed
stretch (security), stretch1.7.6-2+deb9u2fixed
buster, sid1.7.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgcrypt11source(unstable)(unfixed)low
libgcrypt11sourcesqueeze(not affected)
libgcrypt11sourcewheezy1.5.0-5+deb7u4lowDSA-3478-1
libgcrypt20source(unstable)1.6.5-2low
libgcrypt20sourcejessie1.6.3-2+deb8u1lowDSA-3474-1

Notes

[squeeze] - libgcrypt11 <not-affected> (Vulnerable code not present)
http://www.cs.tau.ac.IL/~tromer/ecdh/
http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git;a=commit;h=fcbb9fcc2e6983ea61bf565b6ee2e29816b8cd57 (LIBGCRYPT-1-5-BRANCH)
http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git;a=commit;h=de7db12fa04016e12dffb2b678632f45eba15ec4 (libgcrypt-1.6.5)
http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git;a=commit;h=28eb424e4427b320ec1c9c4ce56af25d495230bd (libgcrypt-1.6.5)
http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git;a=commit;h=88e1358962e902ff1cbec8d53ba3eee46407851a (master)

Search for package or bug name: Reporting problems