CVE-2015-7519

NameCVE-2015-7519
Descriptionagent/Core/Controller/SendRequest.cpp in Phusion Passenger before 4.0.60 and 5.0.x before 5.0.22, when used in Apache integration mode or in standalone mode without a filtering proxy, allows remote attackers to spoof headers passed to applications by using an _ (underscore) character instead of a - (dash) character in an HTTP header, as demonstrated by an X_User header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-394-1
NVD severitymedium (attack range: remote)
Debian Bugs807354, 864651

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
passenger (PTS)buster, sid, stretch5.0.30-1fixed
ruby-passenger (PTS)wheezy3.0.13debian-1+deb7u2fixed
jessie4.0.53-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
passengersource(unstable)5.0.22-1medium807354
passengersourcesqueeze2.2.11debian-2+deb6u1mediumDLA-394-1
ruby-passengersource(unstable)(unfixed)medium864651
ruby-passengersourcewheezy(not affected)

Notes

[wheezy] - ruby-passenger <not-affected> (Vulnerable code not present)
https://bugzilla.suse.com/show_bug.cgi?id=956281
https://github.com/phusion/passenger/commit/ddb8ecc4ebf260e4967f57f271d4f5761abeac3e

Search for package or bug name: Reporting problems