CVE-2015-7546

NameCVE-2015-7546
DescriptionThe identity service in OpenStack Identity (Keystone) before 2015.1.3 (Kilo) and 8.0.x before 8.0.2 (Liberty) and keystonemiddleware (formerly python-keystoneclient) before 1.5.4 (Kilo) and Liberty before 2.3.3 does not properly invalidate authorization tokens when using the PKI or PKIZ token providers, which allows remote authenticated users to bypass intended access restrictions and gain access to cloud resources by manipulating byte fields within a revoked token.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
keystone (PTS)wheezy2012.1.1-13+wheezy1vulnerable
jessie2014.1.3-6vulnerable
stretch, sid2:10.0.0-7vulnerable
python-keystonemiddleware (PTS)jessie1.0.0-3+deb8u1vulnerable
stretch, sid4.9.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
keystonesource(unstable)(unfixed)medium
python-keystonemiddlewaresource(unstable)(unfixed)medium

Notes

[jessie] - keystone <no-dsa> (Too intrusive to backport, needs to switch to different token provider)
[wheezy] - keystone <no-dsa> (Too intrusive to backport, needs to switch to different token provider)
[jessie] - python-keystonemiddleware <no-dsa> (Too intrusive to backport, needs to switch to different token provider)
https://wiki.openstack.org/wiki/OSSN/OSSN-0062
Keystone: <= 2015.1.2, >= 8.0.0 <= 8.0.1
Keystonemiddleware: >= 1.5.0 <= 1.5.3, >= 1.6.0 <= 2.3.2

Search for package or bug name: Reporting problems