CVE-2015-7559

NameCVE-2015-7559
DescriptionIt was found that the Apache ActiveMQ client before 5.15.5 exposed a remote shutdown command in the ActiveMQConnection class. An attacker logged into a compromised broker could use this flaw to achieve denial of service on a connected client.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-913-1
NVD severitymedium
Debian Bugs860866

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
activemq (PTS)jessie5.6.0+dfsg1-4+deb8u3fixed
jessie (security)5.6.0+dfsg1-4+deb8u2vulnerable
stretch5.14.3-3fixed
buster5.15.8-2fixed
bullseye, sid5.15.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
activemqsource(unstable)5.14.3-3860866
activemqsourcejessie5.6.0+dfsg1-4+deb8u3
activemqsourcewheezy5.6.0+dfsg-1+deb7u3DLA-913-1

Notes

Upstream commit: https://git-wip-us.apache.org/repos/asf?p=activemq.git;h=b8fc78e
https://issues.apache.org/jira/browse/AMQ-6470

Search for package or bug name: Reporting problems