CVE-2015-7577

NameCVE-2015-7577
Descriptionactiverecord/lib/active_record/nested_attributes.rb in Active Record in Ruby on Rails 3.1.x and 3.2.x before 3.2.22.1, 4.0.x and 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 does not properly implement a certain destroy option, which allows remote attackers to bypass intended change restrictions by leveraging use of the nested attributes feature.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-496-1, DSA-3464-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)wheezy2:2.3.14.2fixed
jessie (security), jessie2:4.1.8-1+deb8u4fixed
stretch2:4.2.7.1-1fixed
buster, sid2:4.2.9-4fixed
ruby-activerecord-2.3 (PTS)wheezy2.3.14-6vulnerable
ruby-activerecord-3.2 (PTS)wheezy3.2.6-5+deb7u1vulnerable
wheezy (security)3.2.6-5+deb7u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)2:4.2.5.1-1medium
railssourcejessie2:4.1.8-1+deb8u1mediumDSA-3464-1
railssourcesqueeze(unfixed)end-of-life
railssourcewheezy(not affected)
ruby-activerecord-2.3source(unstable)(unfixed)medium
ruby-activerecord-2.3sourcewheezy(unfixed)end-of-life
ruby-activerecord-3.2source(unstable)(unfixed)medium
ruby-activerecord-3.2sourcewheezy3.2.6-5+deb7u2mediumDLA-496-1

Notes

[wheezy] - rails <not-affected> (Vulnerable code not present, is only a transitional package)
[squeeze] - rails <end-of-life> (Not supported in Squeeze LTS)

Search for package or bug name: Reporting problems