CVE-2015-7578

NameCVE-2015-7578
DescriptionCross-site scripting (XSS) vulnerability in the rails-html-sanitizer gem before 1.0.3 for Ruby on Rails 4.2.x and 5.x allows remote attackers to inject arbitrary web script or HTML via crafted tag attributes.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs812814

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-rails-html-sanitizer (PTS)buster1.0.4-1fixed
buster (security)1.0.4-1+deb10u2fixed
bullseye1.3.0-1fixed
bookworm, sid, trixie1.4.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-rails-html-sanitizersource(unstable)1.0.3-1812814

Search for package or bug name: Reporting problems