CVE-2015-7581

NameCVE-2015-7581
Descriptionactionpack/lib/action_dispatch/routing/route_set.rb in Action Pack in Ruby on Rails 4.x before 4.2.5.1 and 5.x before 5.0.0.beta1.1 allows remote attackers to cause a denial of service (superfluous caching and memory consumption) by leveraging an application's use of a wildcard controller route.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3464-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)wheezy2:2.3.14.2fixed
jessie (security), jessie2:4.1.8-1+deb8u4fixed
stretch2:4.2.7.1-1fixed
buster, sid2:4.2.9-4fixed
ruby-actionpack-2.3 (PTS)wheezy2.3.14-5vulnerable
ruby-actionpack-3.2 (PTS)wheezy3.2.6-6+deb7u2fixed
wheezy (security)3.2.6-6+deb7u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)2:4.2.5.1-1medium
railssourcejessie2:4.1.8-1+deb8u1mediumDSA-3464-1
railssourcesqueeze(unfixed)end-of-life
railssourcewheezy(not affected)
ruby-actionpack-2.3source(unstable)(unfixed)medium
ruby-actionpack-2.3sourcewheezy(unfixed)end-of-life
ruby-actionpack-3.2source(unstable)(unfixed)medium
ruby-actionpack-3.2sourcewheezy(not affected)

Notes

[wheezy] - rails <not-affected> (Vulnerable code not present, is only a transitional package)
[squeeze] - rails <end-of-life> (Not supported in Squeeze LTS)
[wheezy] - ruby-actionpack-3.2 <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems