CVE-2015-7674

NameCVE-2015-7674
DescriptionInteger overflow in the pixops_scale_nearest function in pixops/pixops.c in gdk-pixbuf before 2.32.1 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted GIF image file, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-434-1, DLA-450-1, DSA-3378-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gdk-pixbuf (PTS)wheezy2.26.1-1+deb7u3vulnerable
wheezy (security)2.26.1-1+deb7u6fixed
jessie (security), jessie2.31.1-2+deb8u6fixed
stretch (security), stretch2.36.5-2+deb9u1fixed
buster, sid2.36.11-1fixed
gtk+2.0 (PTS)wheezy2.24.10-2fixed
jessie2.24.25-3+deb8u2fixed
buster, stretch2.24.31-2fixed
sid2.24.31-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gdk-pixbufsource(unstable)2.32.1-1medium
gdk-pixbufsourcejessie2.31.1-2+deb8u3mediumDSA-3378-1
gdk-pixbufsourcewheezy2.26.1-1+deb7u4mediumDLA-450-1
gtk+2.0source(unstable)2.21.5-1medium
gtk+2.0sourcesqueeze2.20.1-2+deb6u2mediumDLA-434-1

Notes

http://www.openwall.com/lists/oss-security/2015/10/01/4
Fix for CVE-2015-7674: https://git.gnome.org/browse/gdk-pixbuf/commit/?id=e9a5704edaa9aee9498f1fbf6e1b70fcce2e55aa (2.32.1)
Additional hardening against further overflows (but not part of the CVE assignment): https://git.gnome.org/browse/gdk-pixbuf/commit/?id=dbfe8f70471864818bf458a39c8a99640895bd22 (2.33.1)
The CVE is only assigned for the overflow in the pixops_scale_nearest function.
gtk+2.0 2.21.5-1 removed the embedded copy of gdk-pixbuf and build-depends on external gdk-pixbuf

Search for package or bug name: Reporting problems