Descriptiongifread.c in gif2png, as used in OptiPNG before 0.7.6, allows remote attackers to cause a denial of service (uninitialized memory read) via a crafted GIF file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs801700

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
optipng (PTS)wheezy0.6.4-1+deb7u2vulnerable
wheezy (security)0.6.4-1+deb7u4vulnerable
jessie (security)0.7.5-1+deb8u2vulnerable
stretch (security), stretch0.7.6-1+deb9u1fixed
buster, sid0.7.6-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


Not a security flaw as the under-read does not depend on input

Search for package or bug name: Reporting problems