DescriptionUse-after-free vulnerability in ntpd in NTP 4.2.x before 4.2.8p4, and 4.3.x before 4.3.77 allows remote authenticated users to possibly execute arbitrary code or cause a denial of service (crash) via crafted packets.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ntp (PTS)buster1:4.2.8p12+dfsg-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ntpsourcesqueeze(not affected)
ntpsourcewheezy(not affected)
ntpsourcejessie(not affected)


[jessie] - ntp <not-affected> (Bug introduced in 4.2.7p262)
[wheezy] - ntp <not-affected> (Bug introduced in 4.2.7p262)
[squeeze] - ntp <not-affected> (Bug introduced in 4.2.7p262)

Search for package or bug name: Reporting problems