CVE-2015-7854

NameCVE-2015-7854
DescriptionBuffer overflow in the password management functionality in NTP 4.2.x before 4.2.8p4, and 4.3.x before 4.3.77 allows remote authenticated users to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted key file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ntp (PTS)jessie (security), jessie1:4.2.6.p5+dfsg-7+deb8u2fixed
stretch1:4.2.8p10+dfsg-3+deb9u2fixed
buster1:4.2.8p12+dfsg-4fixed
bullseye, sid1:4.2.8p13+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ntpsource(unstable)1:4.2.8p4+dfsg-1
ntpsourcejessie(not affected)
ntpsourcesqueeze(not affected)
ntpsourcewheezy(not affected)

Notes

[jessie] - ntp <not-affected> (Bug introduced in 4.2.7p262)
[wheezy] - ntp <not-affected> (Bug introduced in 4.2.7p262)
[squeeze] - ntp <not-affected> (Bug introduced in 4.2.7p262)
http://support.ntp.org/bin/view/Main/SecurityNotice#October_2015_NTP_Security_Vulner
https://github.com/ntp-project/ntp/commit/1bb401576f412532d8cdcca5509b85ad29605913

Search for package or bug name: Reporting problems