CVE-2015-7975

NameCVE-2015-7975
DescriptionThe nextvar function in NTP before 4.2.8p6 and 4.3.x before 4.3.90 does not properly validate the length of its input, which allows an attacker to cause a denial of service (application crash).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ntp (PTS)jessie (security), jessie1:4.2.6.p5+dfsg-7+deb8u2fixed
stretch1:4.2.8p10+dfsg-3+deb9u2fixed
buster1:4.2.8p12+dfsg-4fixed
bullseye, sid1:4.2.8p13+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ntpsource(unstable)1:4.2.8p7+dfsg-1
ntpsourcejessie(not affected)
ntpsourcewheezy(not affected)

Notes

[jessie] - ntp <not-affected> (Introduced in 4.2.8)
[wheezy] - ntp <not-affected> (Introduced in 4.2.8)
http://support.ntp.org/bin/view/Main/SecurityNotice#January_2016_NTP_4_2_8p6_Securit
http://support.ntp.org/bin/view/Main/NtpBug2937

Search for package or bug name: Reporting problems