CVE-2015-7984

NameCVE-2015-7984
DescriptionMultiple cross-site request forgery (CSRF) vulnerabilities in Horde before 5.2.8, Horde Groupware before 5.2.11, and Horde Groupware Webmail Edition before 5.2.11 allow remote attackers to hijack the authentication of administrators for requests that execute arbitrary (1) commands via the cmd parameter to admin/cmdshell.php, (2) SQL queries via the sql parameter to admin/sqlshell.php, or (3) PHP code via the php parameter to admin/phpshell.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3391-1
NVD severitymedium (attack range: remote)
Debian Bugs803641

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-horde (PTS)jessie (security), jessie5.2.1+debian0-2+deb8u3fixed
stretch5.2.13+debian0-1fixed
buster, sid5.2.17+debian0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php-hordesource(unstable)5.2.8+debian0-1medium803641
php-hordesourcejessie5.2.1+debian0-2+deb8u2mediumDSA-3391-1

Notes

https://www.htbridge.com/advisory/HTB23272
https://github.com/horde/horde/commit/a199d74932c902844514b2a83d21e7e221257dae
http://lists.horde.org/archives/dev/Week-of-Mon-20141201/028821.html

Search for package or bug name: Reporting problems