CVE-2015-8023

NameCVE-2015-8023
DescriptionThe server implementation of the EAP-MSCHAPv2 protocol in the eap-mschapv2 plugin in strongSwan 4.2.12 through 5.x before 5.3.4 does not properly validate local state, which allows remote attackers to bypass authentication via an empty Success message in response to an initial Challenge message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-345-1, DSA-3398-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
strongswan (PTS)wheezy4.5.2-1.5+deb7u8fixed
wheezy (security)4.5.2-1.5+deb7u10fixed
jessie (security), jessie5.2.1-6+deb8u5fixed
stretch (security), stretch5.5.1-4+deb9u1fixed
buster, sid5.6.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
strongswansource(unstable)5.3.3-3medium
strongswansourcejessie5.2.1-6+deb8u2mediumDSA-3398-1
strongswansourcesqueeze4.4.1-5.8mediumDLA-345-1
strongswansourcewheezy4.5.2-1.5+deb7u8mediumDSA-3398-1

Notes

https://www.strongswan.org/blog/2015/11/16/strongswan-vulnerability-%28cve-2015-8023%29.html

Search for package or bug name: Reporting problems