CVE-2015-8027

NameCVE-2015-8027
DescriptionNode.js 0.12.x before 0.12.9, 4.x before 4.2.3, and 5.x before 5.1.1 does not ensure the availability of a parser for each HTTP socket, which allows remote attackers to cause a denial of service (uncaughtException and service outage) via a pipelined HTTP request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs806385

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nodejs (PTS)jessie0.10.29~dfsg-2fixed
stretch4.8.2~dfsg-1fixed
buster, bullseye10.15.2~dfsg-2fixed
sid10.16.3~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nodejssource(unstable)4.2.3~dfsg-1medium806385
nodejssourcejessie(not affected)

Notes

[jessie] - nodejs <not-affected> (0.10 series not affected)
https://nodejs.org/en/blog/vulnerability/cve-2015-8027_cve-2015-6764/

Search for package or bug name: Reporting problems