CVE-2015-8080

NameCVE-2015-8080
DescriptionInteger overflow in the getnum function in lua_struct.c in Redis 2.8.x before 2.8.24 and 3.0.x before 3.0.6 allows context-dependent attackers with permission to run Lua code in a Redis session to cause a denial of service (memory corruption and application crash) or possibly bypass intended sandbox restrictions via a large number, which triggers a stack-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3412-1
NVD severitymedium (attack range: remote)
Debian Bugs804419

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
redis (PTS)wheezy2:2.4.14-1fixed
wheezy (security)2:2.4.14-1+deb7u2fixed
jessie (security), jessie2:2.8.17-1+deb8u5fixed
stretch3:3.2.6-1fixed
buster, sid5:4.0.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
redissource(unstable)2:3.0.5-4medium804419
redissourcejessie2:2.8.17-1+deb8u3mediumDSA-3412-1
redissourcesqueeze(not affected)
redissourcewheezy(not affected)

Notes

[wheezy] - redis <not-affected> (Vulnerable code not present)
[squeeze] - redis <not-affected> (Vulnerable code not present)
https://github.com/antirez/redis/issues/2855

Search for package or bug name: Reporting problems