CVE-2015-8213

NameCVE-2015-8213
DescriptionThe get_format function in utils/formats.py in Django before 1.7.x before 1.7.11, 1.8.x before 1.8.7, and 1.9.x before 1.9rc2 might allow remote attackers to obtain sensitive application secrets via a settings key in place of a date/time format setting, as demonstrated by SECRET_KEY.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-349-1, DSA-3404-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)wheezy1.4.5-1+deb7u16fixed
wheezy (security)1.4.22-1+deb7u3fixed
jessie (security), jessie1.7.11-1+deb8u2fixed
stretch1:1.10.7-2fixed
buster, sid1:1.11.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosource(unstable)1.8.7-1medium
python-djangosourcejessie1.7.7-1+deb8u3mediumDSA-3404-1
python-djangosourcesqueeze1.2.3-3+squeeze15mediumDLA-349-1
python-djangosourcewheezy1.4.5-1+deb7u14mediumDSA-3404-1

Notes

https://github.com/django/django/commit/316bc3fc9437c5960c24baceb93c73f1939711e4 (master)
https://github.com/django/django/commit/8a01c6b53169ee079cb21ac5919fdafcc8c5e172 (1.7.x)
https://www.djangoproject.com/weblog/2015/nov/24/security-releases-issued/

Search for package or bug name: Reporting problems