CVE-2015-8218

NameCVE-2015-8218
DescriptionThe decode_uncompressed function in libavcodec/faxcompr.c in FFmpeg before 2.8.2 does not validate uncompressed runs, which allows remote attackers to cause a denial of service (out-of-bounds array access) or possibly have unspecified other impact via crafted CCITT FAX data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch (security), stretch7:3.2.10-1~deb9u1fixed
buster, sid7:3.4.2-2fixed
libav (PTS)jessie6:11.11-1~deb8u1fixed
jessie (security)6:11.12-1~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:2.8.2-1medium
ffmpegsourcesqueeze(not affected)
libavsource(unstable)(not affected)

Notes

[squeeze] - ffmpeg <not-affected> (Vulnerable code not present)
- libav <not-affected> (Vulnerable feature not present)
https://git.videolan.org/?p=ffmpeg.git;a=commit;h=d4a731b84a08f0f3839eaaaf82e97d8d9c67da46
Vulnerability affects G3{1, 2}D code extensions feature, which is not present
in libav 0.8 and 9. branches: https://lists.debian.org/debian-lts/2017/12/msg00011.html
11.x features G3 support, but the vulnerable code was introduced later

Search for package or bug name: Reporting problems