CVE-2015-8312

NameCVE-2015-8312
DescriptionOff-by-one error in afs_pioctl.c in OpenAFS before 1.6.16 might allow local users to cause a denial of service (memory overwrite and system crash) via a pioctl with an input buffer size of 4096 bytes.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-493-1, DSA-3569-1
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openafs (PTS)wheezy1.6.1-3+deb7u5vulnerable
wheezy (security)1.6.1-3+deb7u7fixed
jessie (security), jessie1.6.9-2+deb8u5fixed
stretch1.6.20-2fixed
buster1.6.22-1fixed
sid1.6.22-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openafssource(unstable)1.6.17-1medium
openafssourcejessie1.6.9-2+deb8u5mediumDSA-3569-1
openafssourcewheezy1.6.1-3+deb7u6mediumDLA-493-1

Notes

http://git.openafs.org/?p=openafs.git;a=commitdiff;h=2ef863720da4d9f368aaca0461c672a3008195ca
http://rt.central.org/rt/Ticket/Display.html?id=132256

Search for package or bug name: Reporting problems