CVE-2015-8370

NameCVE-2015-8370
DescriptionMultiple integer underflows in Grub2 1.98 through 2.02 allow physically proximate attackers to bypass authentication, obtain sensitive information, or cause a denial of service (disk corruption) via backspace characters in the (1) grub_username_get function in grub-core/normal/auth.c or the (2) grub_password_get function in lib/crypto.c, which trigger an "Off-by-two" or "Out of bounds overwrite" memory error.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-368-1, DSA-3421-1
NVD severitymedium (attack range: local)
Debian Bugs807614

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
grub2 (PTS)wheezy (security), wheezy1.99-27+deb7u3fixed
jessie (security), jessie2.02~beta2-22+deb8u1fixed
stretch, sid2.02~beta3-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
grub2source(unstable)2.02~beta2-33medium807614
grub2sourcejessie2.02~beta2-22+deb8u1mediumDSA-3421-1
grub2sourcesqueeze1.98+20100804-14+squeeze2mediumDLA-368-1
grub2sourcewheezy1.99-27+deb7u3mediumDSA-3421-1

Notes

https://twitter.com/lostinsecurity/status/674925944524640257
http://hmarco.org/bugs/CVE-2015-8370-Grub2-authentication-bypass.html

Search for package or bug name: Reporting problems