CVE-2015-8384

NameCVE-2015-8384
DescriptionPCRE before 8.38 mishandles the /(?J)(?'d'(?'d'\g{d}))/ pattern and related patterns with certain recursive back references, which allows remote attackers to cause a denial of service (buffer overflow) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror, a related issue to CVE-2015-8392 and CVE-2015-8395.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcre3 (PTS)jessie2:8.35-3.3+deb8u4fixed
stretch2:8.39-3fixed
bullseye, sid, buster2:8.39-12fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcre3source(unstable)2:8.35-7.2high
pcre3sourcejessie2:8.35-3.3+deb8u1high
pcre3sourcesqueeze(not affected)
pcre3sourcewheezy(not affected)

Notes

[wheezy] - pcre3 <not-affected> (Vulnerable code introduced later)
[squeeze] - pcre3 <not-affected> (Vulnerable code introduced later)
https://bugs.exim.org/show_bug.cgi?id=1636
related issue to CVE-2015-8392 and CVE-2015-8395
Fixed in 8.38
Fixed by http://vcs.pcre.org/pcre?view=revision&revision=1558
Same fixing commit as CVE-2015-3210 but different issues

Search for package or bug name: Reporting problems