CVE-2015-8392

NameCVE-2015-8392
DescriptionPCRE before 8.38 mishandles certain instances of the (?| substring, which allows remote attackers to cause a denial of service (unintended recursion and buffer overflow) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror, a related issue to CVE-2015-8384 and CVE-2015-8395.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcre3 (PTS)stretch2:8.39-3fixed
buster2:8.39-12fixed
bookworm, sid, bullseye2:8.39-13fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcre3sourcesqueeze(not affected)
pcre3sourcewheezy(not affected)
pcre3sourcejessie2:8.35-3.3+deb8u2
pcre3source(unstable)2:8.38-1

Notes

[wheezy] - pcre3 <not-affected> (Vulnerable code introduced later)
[squeeze] - pcre3 <not-affected> (Vulnerable code introduced later)
Fixed in 8.38
http://vcs.pcre.org/pcre?view=revision&revision=1585
related issue to CVE-2015-8384 and CVE-2015-8395

Search for package or bug name: Reporting problems