CVE-2015-8467

NameCVE-2015-8467
DescriptionThe samldb_check_user_account_control_acl function in dsdb/samdb/ldb_modules/samldb.c in Samba 4.x before 4.1.22, 4.2.x before 4.2.7, and 4.3.x before 4.3.3 does not properly check for administrative privileges during creation of machine accounts, which allows remote authenticated users to bypass intended access restrictions by leveraging the existence of a domain with both a Samba DC and a Windows DC, a similar issue to CVE-2015-2535.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-3433-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)buster, buster (security)2:4.9.5+dfsg-5+deb10u3fixed
bullseye (security), bullseye2:4.13.13+dfsg-1~deb11u5fixed
bookworm, sid2:4.17.3+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasourcesqueeze(not affected)
sambasourcewheezy2:3.6.6-6+deb7u6DSA-3433-1
sambasourcejessie2:4.1.17+dfsg-2+deb8u1DSA-3433-1
sambasource(unstable)2:4.1.22+dfsg-1

Notes

[wheezy] - samba <not-affected> (Only affects 4.0.0 to 4.3.2)
[squeeze] - samba <not-affected> (Only affects 4.0.0 to 4.3.2)
https://www.samba.org/samba/security/CVE-2015-8467.html

Search for package or bug name: Reporting problems