CVE-2015-8472

NameCVE-2015-8472
DescriptionBuffer overflow in the png_set_PLTE function in libpng before 1.0.65, 1.1.x and 1.2.x before 1.2.55, 1.3.x, 1.4.x before 1.4.18, 1.5.x before 1.5.25, and 1.6.x before 1.6.20 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a small bit-depth value in an IHDR (aka image header) chunk in a PNG image. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-8126.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-375-1, DLA-410-1, DSA-3443-1
NVD severityhigh (attack range: remote)
Debian Bugs807112

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpng (PTS)wheezy, wheezy (security)1.2.49-1+deb7u2fixed
jessie1.2.50-2+deb8u3fixed
jessie (security)1.2.50-2+deb8u2fixed
libpng1.6 (PTS)stretch1.6.28-1fixed
buster, sid1.6.34-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpngsource(unstable)(unfixed)high807112
libpngsourcejessie1.2.50-2+deb8u2highDSA-3443-1
libpngsourcesqueeze1.2.44-1+squeeze6highDLA-375-1
libpngsourcewheezy1.2.49-1+deb7u2highDSA-3443-1
libpng1.6source(unstable)1.6.20-1high807112
openjdk-6sourcesqueeze6b38-1.13.10-1~deb6u1highDLA-410-1

Notes

Fixed in 1.6.20, 1.5.25, 1.4.18, 1.2.55, and 1.0.65
https://github.com/glennrp/libpng/commit/7e1ca9ceba4e64259863efdd98bab9b55bdc0b9c
https://github.com/glennrp/libpng/commit/4488a96126bbefda51d07835411d8e847a88b2b7
https://github.com/glennrp/libpng/commit/ad224c6907e8a274f2679eae4c2e3085fdc7e8c8

Search for package or bug name: Reporting problems