CVE-2015-8547

NameCVE-2015-8547
DescriptionThe CoreUserInputHandler::doMode function in core/coreuserinputhandler.cpp in Quassel 0.10.0 allows remote attackers to cause a denial of service (application crash) via the "/op *" command in a query.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs807801

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quassel (PTS)stretch (security), stretch1:0.12.4-2+deb9u1fixed
buster1:0.13.1-1+deb10u2fixed
bullseye, sid1:0.13.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quasselsource(unstable)1:0.12.2-3807801
quasselsourcejessie1:0.10.0-2.3+deb8u2
quasselsourcesqueeze(not affected)
quasselsourcewheezy(not affected)

Notes

[wheezy] - quassel <not-affected> (Vulnerable code not present)
[squeeze] - quassel <not-affected> (Vulnerable code not present)
https://github.com/quassel/quassel/commit/b8edbda019eeb99da8663193e224efc9d1265dc7
Support for oping a whole channel with /op * was only added in
https://github.com/quassel/quassel/commit/7ecbc1bf921880f7b03af779de7d9611853a0d46 (0.10-beta1)
http://www.openwall.com/lists/oss-security/2015/12/12/1

Search for package or bug name: Reporting problems