CVE-2015-8552

NameCVE-2015-8552
DescriptionThe PCI backend driver in Xen, when running on an x86 system and using Linux 3.1.x through 4.3.x as the driver domain, allows local guest administrators to generate a continuous stream of WARN messages and cause a denial of service (disk consumption) by leveraging a system with access to a passed-through MSI or MSI-X capable physical PCI device and XEN_PCI_OP_enable_msi operations, aka "Linux pciback missing sanity checks."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3434-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.78-1fixed
wheezy (security)3.2.93-1fixed
jessie3.16.43-2+deb8u2fixed
jessie (security)3.16.43-2+deb8u5fixed
stretch4.9.51-1fixed
stretch (security)4.9.30-2+deb9u5fixed
buster, sid4.13.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.3.3-3low
linuxsourceexperimental4.4~rc6-1~exp1low
linuxsourcejessie3.16.7-ckt20-1+deb8u2lowDSA-3434-1
linuxsourcewheezy3.2.73-2+deb7u2lowDSA-3434-1
linux-2.6source(unstable)(unfixed)low

Notes

[squeeze] - linux-2.6 <no-dsa> (Xen not supported in Squeeze LTS)
http://xenbits.xen.org/xsa/advisory-157.html
https://git.kernel.org/linus/56441f3c8e5bd45aab10dd9f8c505dd4bec03b0d
https://git.kernel.org/linus/5e0ce1455c09dd61d029b8ad45d82e1ac0b6c4c9
https://git.kernel.org/linus/a396f3a210c3a61e94d6b87ec05a75d0be2a60d0
https://git.kernel.org/linus/7cfb905b9638982862f0331b36ccaaca5d383b49
https://git.kernel.org/linus/408fb0e5aa7fda0059db282ff58c3b2a4278baa0

Search for package or bug name: Reporting problems