CVE-2015-8605

NameCVE-2015-8605
DescriptionISC DHCP 4.x before 4.1-ESV-R12-P1, 4.2.x, and 4.3.x before 4.3.3-P1 allows remote attackers to cause a denial of service (application crash) via an invalid length field in a UDP IPv4 packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-385-1, DLA-385-2, DSA-3442-1
NVD severitymedium (attack range: remote)
Debian Bugs810875

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
isc-dhcp (PTS)wheezy, wheezy (security)4.2.2.dfsg.1-5+deb70u8fixed
jessie (security), jessie4.3.1-6+deb8u2fixed
buster, sid, stretch4.3.5-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
isc-dhcpsource(unstable)4.3.3-7medium810875
isc-dhcpsourcejessie4.3.1-6+deb8u2mediumDSA-3442-1
isc-dhcpsourcesqueeze4.1.1-P1-15+squeeze10mediumDLA-385-2
isc-dhcpsourcewheezy4.2.2.dfsg.1-5+deb70u8mediumDSA-3442-1

Notes

https://kb.isc.org/article/AA-01334

Search for package or bug name: Reporting problems