CVE-2015-8607

NameCVE-2015-8607
DescriptionThe canonpath function in the File::Spec module in PathTools before 3.62, as used in Perl, does not properly preserve the taint attribute of data, which might allow context-dependent attackers to bypass the taint protection mechanism via a crafted string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3441-1
NVD severityhigh (attack range: remote)
Debian Bugs810719

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libfile-spec-perl (PTS)wheezy3.3300-1fixed
perl (PTS)wheezy5.14.2-21+deb7u3fixed
wheezy (security)5.14.2-21+deb7u5fixed
jessie5.20.2-3+deb8u8fixed
jessie (security)5.20.2-3+deb8u9fixed
stretch (security), stretch5.24.1-3+deb9u2fixed
buster, sid5.26.0-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libfile-spec-perlsource(unstable)(unfixed)high
libfile-spec-perlsourcesqueeze(not affected)
libfile-spec-perlsourcewheezy(not affected)
perlsource(unstable)5.22.1-4high810719
perlsourcejessie5.20.2-3+deb8u2highDSA-3441-1
perlsourcesqueeze(not affected)
perlsourcewheezy(not affected)

Notes

[wheezy] - perl <not-affected> (Introduced in 5.20.0)
[squeeze] - perl <not-affected> (Introduced in 5.20.0)
[wheezy] - libfile-spec-perl <not-affected> (Introduced in 3.47)
[squeeze] - libfile-spec-perl <not-affected> (Introduced in 3.47)
http://perl5.git.perl.org/perl.git/commit/130509aa42a87eef258fab0182ee2c7ad16baa8b
https://rt.perl.org/Public/Bug/Display.html?id=126862

Search for package or bug name: Reporting problems