CVE-2015-8704

NameCVE-2015-8704
Descriptionapl_42.c in ISC BIND 9.x before 9.9.8-P3, 9.9.x, and 9.10.x before 9.10.3-P3 allows remote authenticated users to cause a denial of service (INSIST assertion failure and daemon exit) via a malformed Address Prefix List (APL) record.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-396-1, DSA-3449-1
NVD severitymedium
Debian Bugs812077

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bind9 (PTS)stretch1:9.10.3.dfsg.P4-12.3+deb9u6fixed
stretch (security)1:9.10.3.dfsg.P4-12.3+deb9u7fixed
buster1:9.11.5.P4+dfsg-5.1+deb10u1fixed
buster (security)1:9.11.5.P4+dfsg-5.1+deb10u2fixed
bullseye, sid1:9.16.6-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bind9sourcesqueeze1:9.7.3.dfsg-1~squeeze19DLA-396-1
bind9sourcewheezy1:9.8.4.dfsg.P1-6+nmu2+deb7u9DSA-3449-1
bind9sourcejessie1:9.9.5.dfsg-9+deb8u5DSA-3449-1
bind9source(unstable)1:9.10.3.dfsg.P4-6812077

Notes

https://kb.isc.org/article/AA-01335

Search for package or bug name: Reporting problems