CVE-2015-8770

NameCVE-2015-8770
DescriptionDirectory traversal vulnerability in the set_skin function in program/include/rcmail_output_html.php in Roundcube before 1.0.8 and 1.1.x before 1.1.4 allows remote authenticated users with certain permissions to read arbitrary files or possibly execute arbitrary code via a .. (dot dot) in the _skin parameter to index.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-392-1, DSA-3541-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
roundcube (PTS)buster, buster (security)1.3.17+dfsg.1-1~deb10u2fixed
bullseye (security), bullseye1.4.13+dfsg.1-1~deb11u1fixed
bookworm, sid1.6.0+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
roundcubesourcesqueeze0.3.1-6+deb6u1DLA-392-1
roundcubesourcewheezy0.7.2-9+deb7u2DSA-3541-1
roundcubesource(unstable)1.1.4+dfsg.1-1

Notes

http://web.archive.org/web/20160329044421/http://roundcube.net/news/2015/12/26/updates-1.1.4-and-1.0.8-released
https://github.com/roundcube/roundcubemail/commit/10e5192a2b1bc90ec137f5e69d0aa072c1210d6d

Search for package or bug name: Reporting problems