CVE-2015-8776

NameCVE-2015-8776
DescriptionThe strftime function in the GNU C Library (aka glibc or libc6) before 2.23 allows context-dependent attackers to cause a denial of service (application crash) or possibly obtain sensitive information via an out-of-range time value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-411-1, DSA-3480-1, DSA-3481-1
NVD severitymedium (attack range: remote)
Debian Bugs812445

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
eglibc (PTS)wheezy2.13-38+deb7u10fixed
wheezy (security)2.13-38+deb7u11fixed
glibc (PTS)jessie2.19-18+deb8u9fixed
jessie (security)2.19-18+deb8u3fixed
sid, stretch2.24-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)medium
eglibcsourcesqueeze2.11.3-4+deb6u9mediumDLA-411-1
eglibcsourcewheezy2.13-38+deb7u10mediumDSA-3480-1
glibcsource(unstable)2.21-7medium812445
glibcsourcejessie2.19-18+deb8u3mediumDSA-3481-1

Notes

https://sourceware.org/bugzilla/show_bug.cgi?id=18985
https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=d36c75fc0d44deec29635dd239b0fbd206ca49b7

Search for package or bug name: Reporting problems