CVE-2015-8779

NameCVE-2015-8779
DescriptionStack-based buffer overflow in the catopen function in the GNU C Library (aka glibc or libc6) before 2.23 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a long catalog name.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-411-1, DSA-3480-1, DSA-3481-1
NVD severityhigh (attack range: remote)
Debian Bugs812455

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
eglibc (PTS)wheezy2.13-38+deb7u10fixed
wheezy (security)2.13-38+deb7u11fixed
glibc (PTS)jessie2.19-18+deb8u7fixed
jessie (security)2.19-18+deb8u3fixed
stretch, sid2.24-9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)high
eglibcsourcesqueeze2.11.3-4+deb6u9highDLA-411-1
eglibcsourcewheezy2.13-38+deb7u10highDSA-3480-1
glibcsource(unstable)2.21-7high812455
glibcsourcejessie2.19-18+deb8u3highDSA-3481-1

Notes

https://sourceware.org/bugzilla/show_bug.cgi?id=17905#c0

Search for package or bug name: Reporting problems