CVE-2015-8806

NameCVE-2015-8806
Descriptiondict.c in libxml2 allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via an unexpected character immediately after the "<!DOCTYPE html" substring in a crafted HTML document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-503-1, DSA-3593-1
NVD severitymedium (attack range: remote)
Debian Bugs813613

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml2 (PTS)wheezy2.8.0+dfsg1-7+wheezy5vulnerable
wheezy (security)2.8.0+dfsg1-7+wheezy11fixed
jessie (security), jessie2.9.1+dfsg1-5+deb8u5fixed
stretch (security), stretch2.9.4+dfsg1-2.2+deb9u1fixed
buster, sid2.9.4+dfsg1-5.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml2source(unstable)2.9.3+dfsg1-1.1medium813613
libxml2sourcejessie2.9.1+dfsg1-5+deb8u2mediumDSA-3593-1
libxml2sourcewheezy2.8.0+dfsg1-7+wheezy6mediumDLA-503-1

Notes

https://bugzilla.gnome.org/show_bug.cgi?id=749115
Same fix as CVE-2016-1839 seems to resolve the issue

Search for package or bug name: Reporting problems