CVE-2015-8834

NameCVE-2015-8834
DescriptionCross-site scripting (XSS) vulnerability in wp-includes/wp-db.php in WordPress before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a long comment that is improperly stored because of limitations on the MySQL TEXT data type. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-3440.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-633-1, DSA-3639-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10vulnerable
wheezy (security)3.6.1+dfsg-1~deb7u16fixed
jessie4.1+dfsg-1+deb8u14fixed
jessie (security)4.1+dfsg-1+deb8u15fixed
stretch4.7.5+dfsg-2fixed
stretch (security)4.7.5+dfsg-2+deb9u1fixed
buster, sid4.8.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.2.2+dfsg-1medium
wordpresssourcejessie4.1+dfsg-1+deb8u9mediumDSA-3639-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u12mediumDLA-633-1

Notes

https://wordpress.org/news/2015/05/wordpress-4-2-2/
Follow-up patch from 4.2.1 -> 4.2.2 for wp-includes/wp-db.php seems not applied
This looks like a required patch: https://github.com/WordPress/WordPress/commit/a3a76fe665dfb62508a66542390a93445f1f7a59
Changes in wp-includes/wp-db.php: https://github.com/WordPress/WordPress/commit/db8f915ee6c236ee2f39e76781bf42367e3f1490
https://core.trac.wordpress.org/changeset/32387/
Wheezy: https://core.trac.wordpress.org/changeset/32391
Wheezy: https://core.trac.wordpress.org/changeset/32395
Wheezy: https://core.trac.wordpress.org/changeset/32423
Wheezy: https://core.trac.wordpress.org/changeset/32435

Search for package or bug name: Reporting problems