CVE-2015-8852

NameCVE-2015-8852
DescriptionVarnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3553-1
NVD severitymedium (attack range: remote)
Debian Bugs783510

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
varnish (PTS)wheezy, wheezy (security)3.0.2-2+deb7u2fixed
jessie (security), jessie4.0.2-1+deb8u1fixed
stretch (security), stretch5.0.0-7+deb9u2fixed
buster5.0.0-7.1fixed
sid5.2.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
varnishsource(unstable)4.0.0-1medium783510
varnishsourcewheezy3.0.2-2+deb7u2mediumDSA-3553-1

Notes

http://www.openwall.com/lists/oss-security/2016/04/16/1
fixed in 3.0.7 upstream, mark as fixed with first 4.x version in unstable
4.x not affected

Search for package or bug name: Reporting problems