DescriptionVarnish 3.x before 3.0.7, when used in certain stacked installations, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a header line terminated by a \r (carriage return) character in conjunction with multiple Content-Length headers in an HTTP request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs783510

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
varnish (PTS)stretch5.0.0-7+deb9u2fixed
stretch (security)5.0.0-7+deb9u3fixed
buster, buster (security)6.1.1-1+deb10u3fixed
bullseye, bullseye (security)6.5.1-1+deb11u2fixed
bookworm, sid7.1.0-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs

fixed in 3.0.7 upstream, mark as fixed with first 4.x version in unstable
4.x not affected

Search for package or bug name: Reporting problems