CVE-2015-8860

NameCVE-2015-8860
DescriptionThe tar package before 2.0.0 for Node.js allows remote attackers to write to arbitrary files via a symlink attack in an archive.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-tar (PTS)jessie0.1.18-1vulnerable
stretch2.2.1-1vulnerable
buster, sid4.4.6+ds1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-tarsource(unstable)(unfixed)unimportant

Notes

libv8 is not covered by security support

Search for package or bug name: Reporting problems