CVE-2015-8861

NameCVE-2015-8861
DescriptionThe handlebars package before 4.0.0 for Node.js allows remote attackers to conduct cross-site scripting (XSS) attacks by leveraging a template with an attribute that is not quoted.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mustache.js (PTS)jessie0.4.2-2vulnerable
buster, sid, stretch2.3.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mustache.jssource(unstable)(unfixed)unimportant

Notes

node-handlebars only in experimental for now, fixed in 4.0.0
libv8 is not covered by security support

Search for package or bug name: Reporting problems