CVE-2015-8867

NameCVE-2015-8867
DescriptionThe openssl_random_pseudo_bytes function in ext/openssl/openssl.c in PHP before 5.4.44, 5.5.x before 5.5.28, and 5.6.x before 5.6.12 incorrectly relies on the deprecated RAND_pseudo_bytes function, which makes it easier for remote attackers to defeat cryptographic protection mechanisms via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u12fixed
jessie5.6.30+dfsg-0+deb8u1fixed
jessie (security)5.6.33+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch7.0.19-1fixed
stretch (security)7.0.27-0+deb9u1fixed
buster, sid7.0.27-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.6.12+dfsg-1medium
php5sourcejessie5.6.12+dfsg-0+deb8u1medium
php5sourcewheezy5.4.44-0+deb7u1medium
php7.0source(unstable)7.0.0-1medium

Notes

https://bugs.php.net/bug.php?id=70014
https://bugs.launchpad.net/ubuntu/+source/php5/+bug/1534203
http://git.php.net/?p=php-src.git;a=commit;h=16023f3e3b9c06cf677c3c980e8d574e4c162827
Fixed in 7.0.0, 5.6.12, 5.5.28, 5.5.44
http://www.openwall.com/lists/oss-security/2016/04/21/8

Search for package or bug name: Reporting problems