CVE-2015-8868

NameCVE-2015-8868
DescriptionHeap-based buffer overflow in the ExponentialFunction::ExponentialFunction function in Poppler before 0.40.0 allows remote attackers to cause a denial of service (memory corruption and crash) or possibly execute arbitrary code via an invalid blend mode in the ExtGState dictionary in a crafted PDF document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-446-1, DSA-3563-1
NVD severityhigh (attack range: remote)
Debian Bugs822578

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)wheezy0.18.4-6vulnerable
wheezy (security)0.18.4-6+deb7u4fixed
jessie (security), jessie0.26.5-2+deb8u1fixed
stretch0.48.0-2fixed
buster, sid0.57.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersource(unstable)0.38.0-3high822578
popplersourcejessie0.26.5-2+deb8u1highDSA-3563-1
popplersourcewheezy0.18.4-6+deb7u1highDLA-446-1

Notes

https://cgit.freedesktop.org/poppler/poppler/commit/?id=b3425dd3261679958cd56c0f71995c15d2124433
https://bugs.freedesktop.org/show_bug.cgi?id=93476
http://www.openwall.com/lists/oss-security/2016/04/12/1

Search for package or bug name: Reporting problems