CVE-2015-8869

NameCVE-2015-8869
DescriptionOCaml before 4.03.0 does not properly handle sign extensions, which allows remote attackers to conduct buffer overflow attacks or obtain sensitive information as demonstrated by a long string to the String.copy function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-466-1
NVD severitymedium (attack range: remote)
Debian Bugs824139

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ocaml (PTS)wheezy3.12.1-4vulnerable
wheezy (security)3.12.1-4+deb7u1fixed
jessie4.01.0-5vulnerable
stretch4.02.3-9fixed
buster4.02.3-10fixed
sid4.05.0-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ocamlsource(unstable)4.02.3-9medium824139
ocamlsourcewheezy3.12.1-4+deb7u1mediumDLA-466-1

Notes

[jessie] - ocaml <no-dsa> (Minor issue; can be fixed via point release and sheduling binNMUs there)
https://github.com/ocaml/ocaml/commit/659615c7b100a89eafe6253e7a5b9d84d0e8df74#diff-a97df53e3ebc59bb457191b496c90762
http://www.openwall.com/lists/oss-security/2016/04/29/1
Ocaml applications using the patched functions need to be recompiled with the
fixed ocaml version.

Search for package or bug name: Reporting problems