CVE-2015-8874

NameCVE-2015-8874
DescriptionStack consumption vulnerability in GD in PHP before 5.6.12 allows remote attackers to cause a denial of service via a crafted imagefilltoborder call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-482-1, DSA-3587-1
NVD severitymedium (attack range: remote)
Debian Bugs824627

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)wheezy2.0.36~rc1~dfsg-6.1+deb7u2vulnerable
wheezy (security)2.0.36~rc1~dfsg-6.1+deb7u10fixed
jessie2.1.0-5+deb8u9fixed
jessie (security)2.1.0-5+deb8u11fixed
stretch (security), stretch2.2.4-2+deb9u2fixed
buster, sid2.2.5-3fixed
php5 (PTS)wheezy5.4.45-0+deb7u2vulnerable
wheezy (security)5.4.45-0+deb7u11vulnerable
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch7.0.19-1fixed
buster, sid7.0.22-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.2.1-1medium824627
libgd2sourcejessie2.1.0-5+deb8u3mediumDSA-3587-1
libgd2sourcewheezy2.0.36~rc1~dfsg-6.1+deb7u3mediumDLA-482-1
php5source(unstable)5.6.12+dfsg-1unimportant
php5sourcejessie5.6.12+dfsg-0+deb8u1medium
php7.0source(unstable)7.0.0-1unimportant

Notes

https://github.com/libgd/libgd/commit/38241013cc048af7c03daf6e9a75b4f42bffb200
PHP bug: https://bugs.php.net/bug.php?id=66387
Fixed in 5.6.12, 7.0.0
Starting with 5.4.0-1 Debian uses the system copy of libgd

Search for package or bug name: Reporting problems