CVE-2015-8876

NameCVE-2015-8876
DescriptionZend/zend_exceptions.c in PHP before 5.4.44, 5.5.x before 5.5.28, and 5.6.x before 5.6.12 does not validate certain Exception objects, which allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) or trigger unintended method execution via crafted serialized data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.0 (PTS)stretch7.0.33-0+deb9u8fixed
stretch (security)7.0.33-0+deb9u12fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5sourcewheezy5.4.44-0+deb7u1
php5sourcejessie5.6.12+dfsg-0+deb8u1
php5source(unstable)5.6.12+dfsg-1
php7.0source(unstable)7.0.0-1

Notes

Fixed in PHP 7.0.0, 5.6.12, 5.5.28, 5.4.44
PHP bug: https://bugs.php.net/bug.php?id=70121

Search for package or bug name: Reporting problems